UCS Director 5.4 – Post upgrade NetApp storage connection issue

After a recent upgrade to UCS Director 5.4 I noticed that my storage connections were showing a status of failed on the dashboard. I went to Administration -> Physical Accounts -> Physical Accounts. All of my NetApp controllers were offline.
Netapp-fix-1a
I went to edit settings and re-entered my password to make sure that it had been picked up correctly.

Netapp-fix-3
All the settings were fine so I saved them and tested the connection to the controllers again.
Netapp-fix-4

The connection failed with the following error:

500 Connection has been shutdown: javax.net.ssl.SSLHandsakeException:

Server chose SSLv3, but that protocol version is not enabled or not supported by the client.

Well, it seems that the connection now wants to use SSLv3. And I don’t, so we have a bit of a conundrum. I did a search and found that enabling TLS resolves the issue. For more information on TLS check out this Wikipedia page on Transport Layer Security.

Log onto your controller and check the tls options that are currently set.

NetApp_filer> options tls
tls.enable off

Netapp-fix-1

The next step is to enable TLS using the command below and then check that it has been enabled

NetApp_filer> options tls.enable on
NetApp_filer> options tls 
tls.enable on

Once that change has been done test the connection once more and it should now appear successfully.

Netapp-fix-2

It seems that Cisco changed their authentication method slightly to NetApp storage as part of the 5.4 release.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s